Re: [LAU] Segfault using zita-j2a

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: Fons Adriaensen <fons@...>
Cc: <linux-audio-user@...>
Date: Thursday, October 25, 2012 - 9:37 pm

Am 25.10.2012 22:57, schrieb Fons Adriaensen:

Okay, the different classes explain the different behavoirs then because
zretune crashes instantly:

(gdb) r --cent 20 test-orig.wav out.wav

Starting program: /usr/bin/zretune --cent 20 test-orig.wav out.wav

warning: Could not load shared library symbols for linux-vdso.so.1.

Do you need "set solib-search-path" or "set sysroot"?

Program received signal SIGSEGV, Segmentation fault.

0x00007ffff7bd8760 in VResampler::process (this=0x7fffffffcf50) at
vresampler.cc:217

217 vresampler.cc: No such file or directory.

(gdb) q

>

Ya, nevermind it, that's always printed but gdb does its job for
backtraces :)

> This may be unrelated, but I also see frequent errors on

I saw the ALSA-errors, too but can't test it right now since I currently
only have the library-part of zita-alsa-pcmi installed. Will install the
other binaries tomorrow and test it then. I can do tests on a pure
32-bit machine if it helps.

Thanks for the help up to now :)

Jannis
_______________________________________________
Linux-audio-user mailing list
Linux-audio-user@lists.linuxaudio.org
http://lists.linuxaudio.org/listinfo/linux-audio-user

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[LAU] Segfault using zita-j2a, Jannis Achstetter, (Thu Oct 25, 2:54 pm)
Re: [LAU] Segfault using zita-j2a, Robin Gareus, (Thu Oct 25, 3:23 pm)
Re: [LAU] Segfault using zita-j2a, Fons Adriaensen, (Thu Oct 25, 3:51 pm)
Re: [LAU] Segfault using zita-j2a, Jannis Achstetter, (Thu Oct 25, 5:37 pm)
Re: [LAU] Segfault using zita-j2a, Fons Adriaensen, (Thu Oct 25, 8:57 pm)
Re: [LAU] Segfault using zita-j2a, Jannis Achstetter, (Thu Oct 25, 9:37 pm)
Re: [LAU] Segfault using zita-j2a, Fons Adriaensen, (Fri Oct 26, 7:37 am)
Re: [LAU] Segfault using zita-j2a, Jannis Achstetter, (Fri Oct 26, 10:27 am)
Re: [LAU] Segfault using zita-j2a, Fons Adriaensen, (Fri Oct 26, 11:57 am)
Re: [LAU] Segfault using zita-j2a, Jannis Achstetter, (Sat Oct 27, 6:23 pm)
Re: [LAU] Segfault using zita-j2a, Fons Adriaensen, (Fri Oct 26, 7:59 am)
Re: [LAU] Segfault using zita-j2a, Jannis Achstetter, (Thu Oct 25, 4:52 pm)
Re: [LAU] Segfault using zita-j2a, Jannis Achstetter, (Thu Oct 25, 3:49 pm)
Re: [LAU] Segfault using zita-j2a, Robin Gareus, (Thu Oct 25, 3:53 pm)